Actualización del kernel para productos Red Hat Linux 4


Red Hat ha publicado una actualización del kernel de Red Hat Enterprise Linux 4 que solventa varias vulnerabilidades.
Los errores corregidos son:

Una vulnerabilidad está causada por un fallo en el manejo de las señales de la muerte de procesos. Podría ser explotada por un atacante local para mandar señales arbitrarias a los procesos que tienen el bit SUID activo ejecutados por
el usuario.

  • Se ha encontrado un fallo en el sistema de archivos CIFS que podría causar que los valores no enmascarados de un proceso no fueran aceptados en los sistemas de archivos CIFS donde las extensiones UNIX están soportados.
  • Se ha encontrado un fallo en el manejo de los sistemas de 64bits en VFAT compat ioctl. Esto podría ser aprovechado por un atacante local para corromper una kernel_dirent struct y causar una denegación de servicio.
  • Existe un fallo en la arquitectura de sonido ALSA que podría ser aprovechado por un atacante local para ver porciones de la memoria del kernel si tiene privilegios de lectura en el archivo /proc/driver/snd-page-alloc.
  • Se ha encontrado un fallo en el driver SCSI aacraid que podría permitir a un usuario local hacer llamadas ioctl al driver. Llamadas que debieran estar restringidas para el usuario.
  • También se ha localizado un error en el manejo de prio_tree en el soporte hugetlb que podría ser aprovechado por un atacante local para causar una denegación de servicio.
  • Un problema en el tratamiento de procesos zombis podría ser explotado por un usuario local para crear un proceso que no se recoja de forma adecuada provocando una denegación de servicio.
  • Se ha encontrado un fallo en el manejo del sistema de archivos CIFS. La opción de montado sec= no permite el chequeo de integridad des sistema o produce un mensaje de error al ser usada.
  • Por último un error en la implementación del generador de números aleatorios que podría ser explotado por un atacante local para causar una denegación de servicio o escalar privilegios.

Otros bugs adicionales también han sido fijados.

Se recomienda actualizar a través de las herramientas automáticas
up2date.

Más Información:

Important: kernel security update
http://rhn.redhat.com/errata/RHSA-2007-0939.html

Fuente de la Noticia –> Hispasec.com

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s